[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Sc-devel] [windows] Two new win2k bugs related to soundfiles and buffers



Thanks John, very helpful - I'll update the libsndfile tomorrow, hopefully that fixes both issues.

Chris

On 21 Jan 2008, at 19:39, John Glover wrote:

Hello,

Not sure if this has been addressed or not yet, but Buffer.read was
not working for me on XP either. I fixed it by downloading the latest
version of libsndfile (1.0.17) and recompiling with it. This may also
fix the first issue, as the bug was causing incorrect info to be
returned by sf_open.

Not sure what version is in the svn, but the filesize is slightly
different so it may be an older one.


John

On 17/01/2008, James Harkins <jamshark70@xxxxxxxxx> wrote:
Sorry to give you more work, Christoph... :(

1873965 [windows] SoundFile info is wrong after openRead'ing a file
1873963         [windows] buffer reading seems not to work in win2k

On the plus side, I'm now running 3 out of 5 processes in one of my
code examples and it sounds pretty good except for the lack of the
FreeVerb2 ugen. (The other 2 depend on soundfile buffers so I can't
test them now.)

hjh

--
James Harkins /// dewdrop world
jamshark70@xxxxxxxxxxxxxxxxx
http://www.dewdrop-world.net

"Come said the Muse,
Sing me a song no poet has yet chanted,
Sing me the universal."  -- Whitman
_______________________________________________
Sc-devel mailing list
Sc-devel@xxxxxxxxxxxxxxx
http://lists.create.ucsb.edu/mailman/listinfo/sc-devel

_______________________________________________
Sc-devel mailing list
Sc-devel@xxxxxxxxxxxxxxx
http://lists.create.ucsb.edu/mailman/listinfo/sc-devel