[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Sc-devel] server naming conventions cleanup?

Hi Guys

It's pretty difficult to make a clean description of scsynth for the book when there is a lot of apparent inconsistency in naming conventions (unless I'm missing something). I've highlighted the most glaring below:

- Inconsistent use of SC_ prefix: sometimes it's there, sometimes it isn't. This applies to both source files and headers.. often one or the other uses SC_ but not both. I can provide a full table of these if necessary. At a minimum, in terms of types, I'd recommend removing SC from SC_BufReadCommand, SC_SequencedCommand and SC_LibCmd. All other types with SC_ are generic system object (like SC_Lock) which could easily collide if we removed SC. The alternative is to be add SC_ everywhere or remove it everywhere

- Now for the big one: I'd like to see Graph renamed to Synth, and GraphDef renamed to SynthDef. There's 400 occurences of "Graph" in the source code, but the IOUgens seem to be the only plugins which reference the name.

- The other main domain entity with an alias is SndBuf which is generally referred to as Buffer outside the server implementation. I can see why renaming that may be less palatable.