[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Sc-devel] "inNumSamples" misnamed?

I still think it makes sense...
On Nov 26, 2007, at 8:10 AM, Dan Stowell wrote:

If you have a kr UGen with an audio-rate input, inNumSamples==1

I need to loop for 1 sample

If you have an ar UGen with an control-rate input, inNumSamples==64
(or whatever)

I need to loop for 64 samples

Input rate doesn't matter, the number of samples in the loop does.

Don't get me wrong, I could care less about the name. It is a local parameter anyways to the UGen function... it can really be called whatever you want, no?


In many cases your outputs and inputs are at the same rate, which is
when "the number of samples I need to loop for" works fine. But in
those two cases above, it's not quite so clear.

Sc-devel mailing list

/* Joshua D. Parmenter

“Every composer – at all times and in all cases – gives his own interpretation of how modern society is structured: whether actively or passively, consciously or unconsciously, he makes choices in this regard. He may be conservative or he may subject himself to continual renewal; or he may strive for a revolutionary, historical or social palingenesis." - Luigi Nono