[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Sc-devel] "inNumSamples" misnamed?

2007/11/26, kernel <kernel@xxxxxxxxxxxxxxxxx>:
> On 26 Nov 2007, at 15:44, Josh Parmenter wrote:
> > I've never thought of it in terms of input or output, but in terms
> > of the number of samples I need to loop for.
> I agree.  Although if you are doing a filter/waveshaper or other
> processing UGen you can attach some meaning to it I guess.

If you have a kr UGen with an audio-rate input, inNumSamples==1
If you have an ar UGen with an control-rate input, inNumSamples==64
(or whatever)

In many cases your outputs and inputs are at the same rate, which is
when "the number of samples I need to loop for" works fine. But in
those two cases above, it's not quite so clear.