[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Sc-devel] "inNumSamples" misnamed?

I've never thought of it in terms of input or output, but in terms of the number of samples I need to loop for.


On Nov 26, 2007, at 7:36 AM, ronald kuivila wrote:

On Nov 26, 2007, at 10:26 AM, Dan Stowell wrote:

Hi -

UGens' calculation functions take an integer, usually called
"inNumSamples". It's only just occurred to me (while working on a book
chapter), but it isn't anything to do with the number of samples in
the unit's inputs. A better name might be "outNumSamples", surely? Or
am I misunderstanding something?

It's funny how you don't pick up on these things until you get to the
point of trying to explain things to someone else.

Which is probably why the design is not really done until the documentation is completed.....


Sc-devel mailing list

/* Joshua D. Parmenter

“Every composer – at all times and in all cases – gives his own interpretation of how modern society is structured: whether actively or passively, consciously or unconsciously, he makes choices in this regard. He may be conservative or he may subject himself to continual renewal; or he may strive for a revolutionary, historical or social palingenesis." - Luigi Nono