[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Sc-devel] "inNumSamples" misnamed?

Hi -

UGens' calculation functions take an integer, usually called
"inNumSamples". It's only just occurred to me (while working on a book
chapter), but it isn't anything to do with the number of samples in
the unit's inputs. A better name might be "outNumSamples", surely? Or
am I misunderstanding something?

It's funny how you don't pick up on these things until you get to the
point of trying to explain things to someone else.