[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [sc-dev] [approve] Function-bund




On 31 Dec 2005, at 13:09, ronald kuivila wrote:

Hi Scott,

This seems like bloat to me. The problem is that you end up with more and more inconsistent method names (sendBundle has a different meaning as a selector for Server, makeBundle is closer but still not the same).

Fair enough. Ideally perhaps some sort of syntactic sugar would be best for this, but if others don't find it as useful as I would, then perhaps it's not worth the trouble.

To save typing, how about defining a class S that simply redirects methods to Server.default? This would save typing and work anywhere (unlike the current convention of using the interpreter variable s).

I like this idea. Did you mean this as a general thing, or just for me?

S.