[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [sc-dev] [approve] Function-bund



Hi Scott,

This seems like bloat to me. The problem is that you end up with more and more inconsistent method names (sendBundle has a different meaning as a selector for Server, makeBundle is closer but still not the same).

To save typing, how about defining a class S that simply redirects methods to Server.default? This would save typing and work anywhere (unlike the current convention of using the interpreter variable s).

RJK


On Dec 29, 2005, at 7:14 PM, Scott Wilson wrote:

Yeah, but trying to save typing, which is the basic point after all. :-)

Other suggestions for a name?

S.

On 30 Dec 2005, at 00:01, James Harkins wrote:

Maybe just a naming thing. .bund implies that you will get a bundle back.

.sendBundle might be better:

{
  b = Buffer.alloc(...);
  .. .. ..
}.sendBundle;

hjh

On 12/29/05, Scott Wilson <sdwilson@xxxxxxxxxxxx> wrote:
Well, it's not worth it then to me anyway, as I almost never do that,
and thus don't see the point of a shortcut. For cases where you want
the bundle back I'd be happy with makeBundle.

--
James Harkins /// dewdrop world
jamshark70@xxxxxxxxxxxxxxxxx
http://www.dewdrop-world.net

"Come said the Muse,
Sing me a song no poet has yet chanted,
Sing me the universal."  -- Whitman

_______________________________________________
sc-dev mailing list
sc-dev@xxxxxxxxxxxxxxx
http://www.create.ucsb.edu/mailman/listinfo/sc-dev


_______________________________________________
sc-dev mailing list
sc-dev@xxxxxxxxxxxxxxx
http://www.create.ucsb.edu/mailman/listinfo/sc-dev