OK
On Oct 31, 2004, at 7:09 AM, Scott Wilson wrote:
Given the problem I had with this (see my post on the users list)
perhaps it would be worth it to set the default for this to nil. I
don't think this would be likely to break any code, and would
prevent some potential bugs as nil would not work in any math. This
would be functionally equivalent to the way things are now and only
need a small change to asOptionsString. i.e.
if (sampleRate != 0, {
o = o ++ " -S " ++ sampleRate;
});
would just be:
if (sampleRate.notNil, {
o = o ++ " -S " ++ sampleRate;
});
Any objections?
S._______________________________________________
sc-dev mailing list
sc-dev@xxxxxxxxxxxxxxx
http://www.create.ucsb.edu/mailman/listinfo/sc-dev
_______________________________________________
sc-dev mailing list
sc-dev@xxxxxxxxxxxxxxx
http://www.create.ucsb.edu/mailman/listinfo/sc-dev