[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [sc-dev] ...Msg



Thanks, Julian, I thought that looked funny. I can
commit the change tonight.

Shouldn't they rather be as follows? They shouldn't
contain any reference to bundle.

moveBeforeMsg { arg  aNode;
		group = aNode.group;
		^[18, nodeID, aNode.nodeID];
	}
	moveAfterMsg { arg aNode;
		group = aNode.group;
		[19, nodeID, aNode.nodeID];
	}
	moveToHeadMsg { arg aGroup;
		group = aGroup;
		^(aGroup ? group).moveNodeToHeadMsg(this);
	}
	moveToTailMsg { arg aGroup;
		group = aGroup;
		^(aGroup ? group).moveNodeToTailMsg(this);
	}

I really wonder if they should be there like this.
I think the messages moveToTailToBundle etc are valuable,
because they follow the rule that group assignment is done
when the bundle is requested (assuming that later it really is sent
and that the group exists.)
the methods that return a message like moveAfterMsg I think are not so specially useful, as nowadays they all have the same arg order and can, if one doesn't want to make them by hand, derive with .getMsg().

I would vote for removing them.

also mapMsg. well but I wouldn't want to break code.
But I'd like it to be simpler.



In fact, the old way for moveToHeadMsg is an outright
bug, not a naming issue, because
Group-moveNodeToHeadMsg doesn't have a bundle argument
(yet this was specified in Node-moveToHeadMsg).

oh yes.
--








.