[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[sc-dev] ...Msg

Thanks, Julian, I thought that looked funny. I can
commit the change tonight.

Shouldn't they rather be as follows? They shouldn't
contain any reference to bundle.

moveBeforeMsg { arg  aNode;
		group = aNode.group;
		^[18, nodeID, aNode.nodeID];
	moveAfterMsg { arg aNode;
		group = aNode.group;
		[19, nodeID, aNode.nodeID];
	moveToHeadMsg { arg aGroup;
		group = aGroup;
		^(aGroup ? group).moveNodeToHeadMsg(this);
	moveToTailMsg { arg aGroup;
		group = aGroup;
		^(aGroup ? group).moveNodeToTailMsg(this);

In fact, the old way for moveToHeadMsg is an outright
bug, not a naming issue, because
Group-moveNodeToHeadMsg doesn't have a bundle argument
(yet this was specified in Node-moveToHeadMsg).


____   James Harkins /// dewdrop world
\  /   jamshark70@xxxxxxxxx
 \/    http://www.duke.edu/~jharkins

"... love and hot pants, peace, harmony..."
  -- Dick Lee, Hot Pants: The Musical

Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!