[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

sussed re: [sc-dev] bug: server is screwy now



Thread 0 Crashed:
 #0   0x90004868 in free_list_remove_ptr
 #1   0x90004554 in szone_free
#2 0x000137a0 in GraphDef_Load(World*, char const*, GraphDef*) (SC_GraphDef.cpp:327) #3 0x00013954 in GraphDef_LoadDir(World*, char*, GraphDef*) (SC_GraphDef.cpp:357)
 #4   0x00006580 in World_New (SC_World.cpp:192)
 #5   0x00003328 in main (scsynth_main.cpp:148)
 #6   0x00002b40 in _start (crt.c:267)
 #7   0x000029c0 in start


its a bug in the GrafDef_Load.

i had all those "UGens not installed" synthdefs in my directory, it was choking on those.
cleared out the dir, server boots once again.



but then my next stupid mistake:

{
	PlayBuf.ar(l.buffer.id,l.sampleRate,1,0,0,l.end);
}.play

which should have been

{
	PlayBuf.ar(l.numChannels,l.buffer.id,1.0,1.0,0.0,1.0);
}.play


so numChannels probably shouldn't be 0 and the bufferID not 44100.0
or we crash thusly:


Thread 3 Crashed:
 #0   0x900051a8 in szone_malloc
 #1   0x90005024 in malloc_zone_malloc
 #2   0x00023ca4 in __cxa_allocate_exception (scsynthsend.cpp:46)
#3 0x00014090 in DoBufferColoring(World*, GraphDef*) (SC_GraphDef.cpp:557) #4 0x00013298 in GraphDef_Read(World*, char*&, GraphDef*) (SC_GraphDef.cpp:227) #5 0x00012e4c in GraphDefLib_Read(World*, char*, GraphDef*) (SC_GraphDef.cpp:143) #6 0x000136fc in GraphDef_Load(World*, char const*, GraphDef*) (SC_GraphDef.cpp:318) #7 0x0000d188 in LoadSynthDefCmd::Stage2() (SC_SequencedCommand.cpp:882) #8 0x00009968 in SC_SequencedCommand::CallNextStage() (SC_SequencedCommand.cpp:108) #9 0x00009684 in SC_SequencedCommand::DoCommand() (SC_SequencedCommand.cpp:67) #10 0x00009834 in DoSequencedCommand(FifoMsg*) (SC_SequencedCommand.cpp:86)
 #11  0x00062bec in FifoMsg::Perform() (SC_CoreAudio.cpp:51)
#12 0x00062518 in MsgFifo<FifoMsg, (int)1024>::Perform() (SC_CoreAudio.cpp:53) #13 0x000168bc in SC_CoreAudioDriver::RunThread() (SC_CoreAudio.cpp:478)
 #14  0x0001601c in core_audio_thread_func(void*) (SC_CoreAudio.cpp:282)
 #15  0x90021308 in _pthread_body

-felix